Resolved
The deployed fix has resolved the cause of the stalled payment screenings.
Monitoring
The affected payment screenings have now been unblocked and we are now monitoring the situation. A fix is being tested to prevent future payment screenings from being affected in the same manner, and this will be deployed once testing is complete.
Identified
A small number of payment screenings are stalled and unable to progress. We have identified the cause and are working to provide a resolution to allow the affected screenings to progress.
Investigating
We are currently investigating issue to our services and will keep our status page up to date with any developments.