Resolved
The payment screening service is now operating normally and the delayed screenings have been successfully processed. We will continue to monitor the service during the day to ensure no further problems arise.
Monitoring
We have identified the issue with the payment screening service and a fix has been deployed. Delayed payment screenings are being now being processed. We will continue to monitor the payment screening service to ensure it remains stable.
Investigating
We are currently investigating an outage with our payment screening service and will keep our status page up to date with any developments.